Friday 29 August 2014

Windows 8.1 - Switching to Local Account


Microsoft Windows 8.1 update by default prompts to use a Microsoft live account and without noticing, I just went ahead and got signed in using my Microsoft Account. Now how do I switch to a local account?


Yes, Windows 8.1 by default takes the users to sign in using Microsoft live account. However, if you carefull observe, you have the option to use a local account, but Microsoft ensured that you will miss that. Windows however allows users to switch between live account and local accounts.  To switch to a local account, follow these steps:

  • Goto Your Account Settings screen. You can do this by typing "Your Account" on the Windows Search screen (Windows Key + Q) .  

  • You will see a link "Disconnect" under your user account. You should click on Disconnect, which will take you through setting up your local account.

  • As a next step, Windows will have to authenticate you once again and will prompt for your current password.
  • The next step will prompt you for inputs to have your local account created. 
  • You will then be prompted for a confirmation and you click on the Singout and Finish button.

You may want to note that by switching to your local account, you will lose the synchronization with your sky drive.

Sunday 24 August 2014

Error connecting to SMTP Server


All of you would have faced issues when connecting to a remote server on ceertain ports. The issue will be strange to trouble shoot as the same connection works from a different network or on the server and so on. I came across such a situation when building and testing a mailing component and I experienced that the .NET SmtpClient component was encountering exception. It took considerable time for me to trouble shoot and get it resolved.


My first take was to try whether the credentials that I have used is just fine, by creating an email account in outlook and that worked fine. I just wanted to isolate various probable areas of concern. As such I then tried using an online SMTP server test service, which was showing an error that the client must first check for incoming mails. Telnet to the mailserver on port 25 also gave an error. I then examined our mail server, whether it has any such restrictions, but I could not find any specific restriction that could cause this issue.

My next step was to examine the details of the exception for any possible clues. The inner exception nested couple of levels deep revealed the error as "An attempt was made to access a socket in a way forbidden by its access permissions"

I then tried looking for solutions online there were many posts and one solution was about to try the following and one of that could solve this issue:
  • Restart the windows firewall service
  • Reboot the problematic machine
  • Restart the “TCP/IP stack”. Run CMD as administrator, type “netsh int ip reset resetlog.txt” to reset TCP/IP.
  • Try to temporarily disable antivirus.
After a bit of analysis, I could find that in my case it was the McAfee Endpoint Protection. I could find that the rule "Prevent mass mailing worms from sending mail" was set to block connections on port 25 with certain exceptions. I added the VWDExpress.exe to the exception list and then it started working fine.

Saturday 2 August 2014

Losing Wi-Fi connection after sleep


I use a HP Probook Laptop at home running Windows 8.1 pro. I usually close the laptop whenever I take a short break so that I can resume my work where I left after the break. But, I find that upon opening the Laptop, the wifi does not connect and that too randomly. That means, it works fine on certain occasions and it doesn't on certain occasions. Some times, a restart helps connecting but not always. What could be the problem and how to get this resolved.

By: Lalith Venkateswaran


This could be due to a combination of multiple issues relating to the configurations in your laptop and as well as on your router.

Upon closing the lid, the laptop goes to sleep mode and powers down the built in wifi device. Which might cause orphaned IPs at your router end and as you reconnect again and again, you might exhaust the DHCP range that your router is configured with. Check if this issue happens when you are on battery. If yes, then you may configure your power options so that your device does not get powered down, every time you close your laptop. You find this setting in the Power management tab of the wifi-adapter configuration. You may also review the advanced power settings for the wifi adaptor under the power options.

When your wifi connection fails upon wake up, you may check if you are able to connect to a different wifi network. If you don't have a different wifi network, you simply use the hotspot feature on your smartphone and try if your laptop can connect to it. If yes, then it is not just the wifi device on your laptop, it could be due to issues with your wifi router as well. Some routers may have issues in accepting connections from the same devices with the same mac id, as the previous connection might still be there. Try the following steps, which might solve your problem:

  • Try setting a shorter DHCP lease time, so that the orphaned connections get released sooner, so that your router has no problem in accepting a fresh connection.
  • Use the DHCP reservation, so that every time the laptop tries to establish a connection, the router assigns the same IP and thus no need for lease expiry / renewal.

Post a comment if this does not solve your problem.